Some users may be unable to access their Exchange Online mailboxes via any connection method.
Incident Report for HJS Technology
Resolved
This incident has been resolved.
Posted Jun 23, 2022 - 10:13 BST
Update
We are continuing to monitor for any further issues.
Posted Jun 21, 2022 - 17:27 BST
Monitoring
We’re continuing to see improvement in availability across the affected services, with some services reporting full recovery.
Posted Jun 21, 2022 - 17:27 BST
Identified
We've identified that our traffic management infrastructure is not working as expected. We've successfully rerouted traffic, and we're seeing an improvement in service availability.
Posted Jun 21, 2022 - 13:00 BST
Update
We've determined multiple Microsoft 365 services are experiencing delays, connection and search issues and are investigating the cause of this.
Posted Jun 21, 2022 - 12:48 BST
Update
We are continuing to investigate this issue.
Posted Jun 21, 2022 - 11:36 BST
Update
We are continuing to investigate this issue.
Posted Jun 21, 2022 - 11:35 BST
Investigating
Users may be unable to access their Exchange Online mailboxes via any connection method.

Current status: We're continuing to analyze service monitoring telemetry to identify the next troubleshooting steps to mitigate the impact.
Posted Jun 21, 2022 - 11:34 BST
This incident affected: Microsoft 365 (Exchange Online (email)).